ubuntu 解决libsqlite3-0依赖的问题(推荐)

fan@fan:sqlite$ sudo apt-get install sqlite3

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

您可能需要运行“apt-get -f install”来纠正下列错误:

下列软件包有未满足的依赖关系:

libsqlite3-dev:i386 : 依赖: libsqlite3-0:i386 (= 3.7.2-1ubuntu0.1) 但是 3.7.9-2ubuntu1.2 正要被安装

sqlite3 : 冲突: sqlite3:i386

sqlite3:i386 : 冲突: sqlite3

E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

解决方法

sudo dpkg --purge --force-depends libsqlite3-0
sudo apt-get install libsqlite3-0
sudo apt-get install -f
sudo apt-get install libsqlite3-dev

以上这篇ubuntu 解决libsqlite3-0依赖的问题(推荐)就是小编分享给大家的全部内容了,希望能给大家一个参考,也希望大家多多支持。

若文章对您有帮助,帮忙点个赞!

0
2
发布时间 2017-05-19 19:45:42
0 条回复(回复会通过微信通知作者)
点击加载更多评论
登录 后再进行评论
(微信扫码即可登录,无需注册)