ADSL共享上网方式大总结（图解）I

一、非路由共享

    1.双机共享上网

    （1）网络连接

    如果你想额外添加一台计算机共享 ADSL上网，那么你须要再购买两块网卡，一块安装在Internet接入计算机中，另一块安装在须要进行共享的那台计算机(以下称为客户机)中。我们建议选购10/100Mbps白适应网卡。值得—提的是，如果 ADSL MODEM是外置以太网接口的，那么Internet接入计算机里面便会有两块网卡，一块用于连接MODEM，另一块用于连接另外一台计算机。当然，一根足够长的双绞线电不可少。需要说明的是：这根用于直接连接两合计算机的双绞线是交叉双绞线，也就是说线的两头排线方式不同，分别是T568A和T568B标准，如图1。

图1

    建议大家在购买双绞线时让商窜帮你做好，但是你一定要告诉是用于两台计算机直接连接。双机共享的组网方式如图2所示。

图2

    （2）网络配置

    将两合计算机按图2所示的方式连接起来以后，我们启动计算机给两块网卡安装驱动程序。待网卡驱动程序安装完成且能够正常工作时，TCP／IP网络协议也已经自动添加了。以后如果因为某种原因(例如TCP／IP~a件受损)，需要人工添加TCP／IP协议时，我们可以在系统桌面上用鼠标右击“网上邻居”图标，在弹出的快捷菜单中选择“属性”，打开“网络和拨号庄接”对话框，然后在对应的连接项目上再次右击鼠标，在弹出的快捷菜单中选择“属性”，打开“连接属性”对话框。在该对话框中点击’安装”按钮，然后在弹出的对话框巾选中“协议”并点击“添加”按钮，晨后在弹出的“选择网络协议”对话框中选择“TCP／IP协议”，“确定”即可，当两合计算机的网卡能够正常工作，且网线连接也正常后．我们须要给两合计算机分别指定IP地址，让它们互能访问。

    a.接入Internet计算机的网络配置
    在Internet接入计算机上，按照上面所述的方法打开“网络和拨号连”对话框。由于这台计算机同时也有ADSL连接，所在该对话框中，现在应该有两个连接项目，一个是用于ADSL连接的，另一个是用于后者——“本地连接”。但若我们打开“网络和拨号连接’对话框时，发现里面存在两个本地本地连接的，也就是用于两个计算机的连接（图3）。

图3

    我们须要指定IP地址的是后者－－“本地连接”。但若我们打开“网络和拨号连接”对话框时，里面存在两个本地连接——“本地连接1”与“本地连接2”，我们则须要判断哪个是真正的本地连接，而哪个是用于ADSL线路的连接。有十很简单的判别方式，那就是在汁算机屏幕右下角托盘区断开ADSL拨号连接，这时它所对应的那个连接就会呈现灰色，而剩下的依旧呈现绿色的连接项目就是真正的本地连接了。鼠标右击”本地连接”，在弹出的快捷菜单中选择“属性”，打开“本地连接属性”对话框。在该对话框中，选择“Internet协议(TCP／IP)”，然后点击“属性”按钮，弹出“Internet协议(TCP／ IP)属性”对话框。在该对话框中，我们先勾迭“使用下面的IP地址”，然后在“IP地址”栏中，输入“192.168.0.1”，在“子网掩码”栏中输入"255.255.255.0"。然后再勾选“使用下面的DNS服务器地址”，并在“首选DNS服务器”栏中输入你的ISP的DNS服务器地址(如果你不清楚，可以致电当地电信局询问)，如图4。

图4

    以上步骤完成并确认后，我们回到系统桌面，鼠标右击“我的电脑”图标，在弹出的“系统特性”对话框中选择“网络标识”标签页。在该标签页中点击”属性”按钮，弹出“标识更改”对话框。在这里，我们须要给计算机命名并设置“工作组名”（注意不是“域名”）。

    b.客户机的网络配置

    同样进入“本地连接属性”对话框，选择“Internet协议(TCP／IP)”，然后点击“属性”按钮，弹出“Internet协议(TCP／IP)属性”对话框。在该对话框中，我们须要将IP地址设定成与 Internet接入计算机相同的网段，即192．168．0．x(x为2-255的自然数)。在本例中，我们将IP地址指定为“192．168．0．2"，子网掩码“255．255．255．0"。由于我们采用网关方式共享 Internet，即把Internet接入计算机当成网关计算机，所以，默认网关应填写Internet接入计算机的IP地址“192．168．0．1”，而首选 DNS服务器也填写“192．168．0．1”。以上设置完成并“确定”后，返回系统桌面。然后按照“接入Internet计算机的网络配置”方法，给这台客户机设置“计算机名”和“工作组名”。注意：每台计算机的名称是惟一的，不能相同，但是工作组要采用相同的名称。设置基本完成，我们可以在两台计算机的“网上邻居”中看能不能显示出对方计算机名，如果能，则组网成功。

    （3）实现internet连接共享

    下一步要做的，就是在接入Internet计算机上安装一个代理服务器软件，或者是网关软件，来实现Internet的连接共享。代理服务器软件能够实现的功能要多一些，但是配置起来比较麻烦；网关软件功能相对代理服务器软件功能弱一些，但是对于小型网络共享已经是绰绰有余，最重要的是——它配置简单!在此我们推荐使用网关软件SyGate。相信大家对它不会陌生，我们在共享56K MODEM上网时就会用到它。它的新版本不仅能够良好地支持ADSL等宽带接入方式的共享，而且依旧保持了小巧轻便、配置简单的风格，所以特别适用于家庭、网吧或中小型办公室。 SyGate能够支持所有的Windows版本，软件的下载地www.onlinedown.net/sygate.htm。下载并安装该软件，它会自动检测硬件以及网络配置，惟一需要注意的是：当系统询问你是否要采用并配置DHCP(自动获取IP地址)服务时，一定要选“否”，因为我们已经给两台计算机配置了固定IP地址。安装完成后重启计算机，SyGate会自动加载。现在，Internet接人计算机便成为一台网关计算机了，当它连接上Internet时，另外一台计算机便可以通过它来上网。Internet接入计算机进行ADSL虚拟拨号连接上网后， SyGate会侦测到Internet连接已建立并自动开始共享该连接(图5)。

图5

    现在客户机可以上网了，大功告成了。

2.多机共享上网

    多机共享是指除了 Internet接入计算机外，还有两台或两台以上的计算机需要共享上网。我们依旧沿用上一篇“双机共享上网”即代理服务器／网关计算机的思路。但由于计算机总数超过了两台，所以我们无法直接用网线将它们连接在一起实现相互通讯，而需要集线设备 (集线器或者交换机)的帮助了。

    我们需要为每台计算机再配置一块网卡，然后，依据需求购买集线器或者交换机。如果计算机总数在8台以内，建议大家购买8口的集线器；如果数量比较多，且除了共享上网，还有别的共享需求(例如单位和网吧)，则建议大家购买16口或者24口的交换机。推荐购买国内知名品牌，价格不贵，性能也不错。多机共享的组网如图6所示。

图6

    需要提醒大家的是，在用集线器或者交换机组网时，采用的是直通双绞线；即线两头都采用T568B做法(连接计算机和ADSL MODEM的那根双绞线也是直通线)。

    网络硬件连接完成后，启动计算机安装网卡驱动程序和TCP／IP协议。如果是网吧，还需要安装IPX／SPX兼容协议，因为局域网连机游戏会用到它。IPX／SPX兼容协议的添加和TCP／IP协议的添加相同，也在“网络属性”对话框中。

    在配置IP地址时，我们依旧将接人Inter— net计算机的IP地址配置为“192．168．0．1”，子网掩码为“255．255．255．0'’，DNS服务器还是填写ISP的DNS服务器地址。

    各客户机的IP地址则顺延下去，分别是“192．168．0．2、192．168．0．3……”，子网掩码依旧采用“255．255．255．0”。而“网关”千13"DNS服务器”还是填写接入Internet计算机的IP地址“192．168．0．1”。

    在对Internet接人计算机和客户机命名时，依旧采用同样的工作组名和不同的计算机名。例如IP地址为“192．168．0．1”的计算机则命名为“a1，依此类推。

    在各台计算机上点击“网上邻居”查看，若可见其它机器，则组网成功。

    最后，还是在Internet接人计算机上安装网关软件SyGate使它成为网关计算机，同样我们也不采用DHCP方式。当网关计算机连接Internet时，SyGate会自行启动连接共享。

3.邻里特殊组网方案

    邻里共享一条ADSL线路的人很多，虽然就是“双机共享上网”，但它有着特殊性，就是在Internet接入计算机关闭后(例如主人不在家，或要关闭计算机时)，另一个用户就无法使用了。不过这并不是无法解决的问题。如果你使用的是以大网接口ADSL MODEM，则可以采用“临时更换线路”的方式来解决这个问题。

    在前面“双机共享上网”的图2组网方案，我们假设Internet接入计算机为A机，而邻居的那台计算机为B机。现在如果A机关闭，B机就无法上网了。不过在我们对连线方式稍做改动之后，问题就可以解决了。

    具体的改动方式有两种，形式稍有差异，但实质相同：

    方案一：

    如图1所示，我们在两机之间再布置一条备用的直通双绞线(注意一定是直通双绞线，即两头都是T568B接头)。这样，在A机需要关闭时，A机用户可以将原本连接ADSL MODEM的双绞线取下来，插上这根备用直通双绞线。然后通知 B机用户，B机用户也把交叉双绞线线取下，插上这根直通双绞线。这，时，就相当于ADSL MODEM直接连接在B机上了。

图7

    当然，这种方式也存在一定问题，一是每次A用户都得通知B用户，显得很麻烦；二是当A用户通知B用户时，B用户可能不在家……于是我们给出第二种方式。

    方案二：

    在ADSL MODEM出口处，加上一个分线器。该分线器原理类似电话的分线器，即1口分两口，并联。这种分线器可以在电脑城中销售网络产品的公司处买到。加上分线器以后，拉出两条直通双绞线，一条接入A机，另外一条走线到B用户处，但不做连接。然后，再按照双机共享方式，即图2所示方式进行组网连接，最后得到如图2所示的组网图。这样，当A机关闭时，A用户根本不用通知B用户。B用户连接网络时，发现无法连通，Ping A机IP地址也无法Ping通，即可确定A机已关闭。然后B机用户拔下原有交叉双绞线，插上备用的直通线直接连接ADSL MODEM即可。

图8

    这种方式便很好地解决了第一种方式所存在的问题。然而，它也并非完美无缺：用户B不能准确判断A机是否关闭且一段时间内不会使用网络。当A机正在启动，或只是短时间关闭时，用户B发现A机无法连通，则主动连接ADSL MODEM，这时A机再连接ADSL时就会失败。具体采用那种方式，大家可根据白己的实际情况而定。

    采取了上述步骤后，我们还没有彻底地解决问题。由于B机直接连接 ADSL MODEM进行主叫拨号，所以需要安装虚拟拨号软件(例如Enternet 300)，且在拨号前要对网络配置进行小小的调整：在“网络属性”对话框中，将已经设置好的"IP地址”和"DNS服务器”改为“自动获取”(也有可能需要指定为别的IP地址，视MODEM的品牌不同具体而定)。这些调整花不了多少时间，一般不到2分钟就可以搞定。

    如果你的ADSL MODEM是采用USB接口的，或者是内置PCI类型的，那么，你无法使用“临时线路修改”的办法来解决问题。因为B机无法直接与ADSL MODEM取得联系。但是严格地说，也不是一点办法都没有。只要A机用户允许，我们可以在“双机共享”的基础上，采用“远程唤醒干自动拨号”的方式来解决问题：从B机上直接唤醒关闭·的A机，并让A机在开机后自动拨号连接Internet，而B机照样通过A这台网关计算机上网。


ADSL共享上网方式大总结（图解）Ⅱ

二、路由共享

    在非路由共享中，我们讲述了非路由以大式、USB式、内置PCI式ADSL MODEM的连接共享方案。它们需要用一台计算机当作代理服务器或网关，而其他计算机通过它来共享上网。而采用路由ADSL MODEM来组网实现连接共享时，由于路由 ADSL MODEM自身集成了拨号功能，且具有单独的IP地址，就相当于一台网关计算机。因此，所有计算机就可以通过这个 ADSL MODEM网关来共享上网，而不再需要单独的代理服务器或网关计算机了。相对来说，这种组网方式更为快捷简便。

    如果你今天才安装，或者才打算安装ADSL，那么恭喜你，因为现在的以太式ADSL MODEM几乎都内置了路由功能(但请注意：只有以太网式ADSL MO— DEM才可能具有路由功能， USB接口式和内置PCI式是不可能具有路由功能的)。但是ISP给我们配置ADSL线路时，出于某些考虑，通常都不会告诉用户路由功能如何使用，更有甚者，干脆警告用户不能使用路由功能，这是完全没有道理的行为!

    通过路由功能，我们可以方便地进行组网和Internet共享，当然，事先我们要开启ADSL MODEM的路由功能，并对它进行一定的配置。下面，笔者就以合勤P642路由ADSL MODEM为：例来为大家讲解如何设置ADSL：路由方式共享上网。其他品牌路由ADSL MODEM的设置界面和它不尽相同，但要设置的项目都是大同小异。

    1.路由ADSL MODEM组网共享

    （1）网络连接

    使用路由ADSL MODEM共享上网，需要购买单独的集线设备(集线器或交换机)，当然，如果ADSL MODEM自身集成了交换机(例如TP-Link的TD-8831)就不用再购买集线设备了。另外，我们需要给每台计算机配置一块网卡，并需要若干条直通双绞线。组网方式如图1所示。

图1

    （2）路由功能的设置

    由于ISP给我们配置ADSL MODEM时，并没有开启路由功能，所以在网络连接完成后，我们还需要修改ADSL MO- DEM的一些设置。

    合勤P642 ADSL MODEM是通过“Telnet'’命令登录至MODEM中进行设置的。它的出厂默认IP地址是192．168．1．1，子网掩码是255．255．255．0，登录密码为1234。在开始设置之前，我们需要将网络中一台计算机的IP地址设置为与之相同的IP段——192．168．1．x(x为2~254之间的自然数)，子网掩码为255．255．255．0，这样才能够登录ADSL MODEM并对它进行设置。

    具体设置步骤如下：

    a．单击“开始一运行”，输入"telnet 192．168．1．广并按“回车”键确认。

    b．在弹出的登录对话框中输入ADSL MODEM的初始管理密码1234，然后按“回车”键进入SMT(System Management Ter— minal，系统管理终端)界面(图2)。

图2

    SMT是合勤P642 ADSL MODEM的设置工具，它分成了3个主要部分：“Getting Started”用于基本的上网设置；“Advanced Applications”是高级应用方面的设置，而“Advanced Management”则是高级管理设置。所有功能的设置只须选择相应的菜单，填入相关的参数就可完成。

    我们需要设置的项目，主要在"Getting Started"中。

    c．设定“Getting Started'’
    进行常规设置，选择菜单“1．General Setup”(常规设置)，进入“常规设置”界面(图3)。

图3

    这里的设置比较简单，上面3个项目System Name (系统名称)、Location(位置)和Contact Per~n’s Name(管理员姓名)根据自己的情况随便填就可以了。关键在下面部分，因为我们要开启路由模式，必须将Route IP(路由IP协议)项设为Yes，Route IPX(路由IPX协议)项设为No，Bridge(桥接模式)设为No。完成此菜单的设定后，按下“回车”键确认设定值。

2.进行以太网设置

    选择菜单“3．Ethernet Setup"(以太网设置)，进入以太网设置界面(图4)

图4

    再选择菜单“2．TCP／IP and DHCP Setup”，进入“TCP／IP and DHCP Setup”的设置界面。这里设置的项目较多，而且都很重要，需要仔细设置。

    首先我们看 看“DHCP”项(动态主机配置协议)，它可以有3种设置，分别是None(没有)、Server(服务器)和Relay(转播)。当设定为Server时ADSL MODEM内置的DHCP服务器就被激活，可以为图1所示的局域网内的客户机分配IP地址、网关地址及DNS服务器地址；若设定为None，内置的DHCP服务器将被关闭，我们需要手动设置局域网中客户机的IP地址。

    在这里，我们建议大家不使用DHCP功能，而采用手动分配局域网中IP地址的方式。于是，我们选定为None(图5)。

图5

    接下来我们要设置TCP／IP参数。

    IP Address，是指ADSL MODEM的默认私有IP地址。我们可以在这里对该 IP地址进行修改。如果不打算修改，保持默认的 192．168．1．1即可。

    IP Subnet Mask(1P子网掩码)。ADSL MODEM会依据你所指定的IP地址自动计算子网掩码。例如当IP地址为192．168．1．1时，子网掩码会自动生成为255．255．255．0。建议保持该自动生成值，而不要人为修改它。完成此菜单的设定后，按下“回车”键确认设置。

    进行Internet访问设置

    在“Getting Started”中选择菜单“4． Internet Access Setup”，进入“Internet访问设置”界面(图6)。我们需要对以下项目进行设置： ISP’s Name(1SP名称)、 Encapsulation(封装模式)、 Multiplexing(多路复用)、VPI(虚拟路径鉴别)和VCI(虚拟通道鉴别)值、Service Name(服务名称)

    以上这些项目要依据ISP提供的参数来设定，请致电ISP询问。

    My login(用户名)与My Password(密码)，这个容易理解。如果你是ADSL拨号用户就在此输入ISP提供给你的用户名和密码。

    Single User Account(单用户账户)，当然选Yes啦，表示只有一个账号。

    IP Address Assignment(1P地址分配)，如果你是ADSL拨号用户，就选Dynamic(动态)，也就是说采用的是动态分配公有IP地址。如果你是ADSL专线用户，就选Static(静态)，并在下面的IP Address栏中输入ISP分配给你的公有IP地址。由于我是采用ADSL虚拟拨号方式，是动态IP地址，所以选择了Dynamic。设置完成后，按“回车”键确认设置。

    d．进行远程节点设置
    在图2所示的主界面中选择菜单“11． Remote Node Setup”，进入远程节点设置界面。这里一共可以设置8个远程节点，现在我们只设置了一个。选择“1”，进入该节点的设置界面。这里的设置项目相当于前面几个项目的集合，参照前面的设置修改相应的参数即可，不过要注意前后一致。

    设置完成后，按“回车”键确认设置。此时若ADSL MODEM设置正确，将自动拨号连接到Internet。

    3.客户机配

    我们在ADSL MODEM的设置中关闭了DHCP功能，所以现在要手动设定局域网中每一台计算机(客户机)的IP地址。有几点需要注意：第一，局域网中计算机的IP地址必须与ADSL MODEM同网段，即IP地址为192．168．1》， 而子网掩码为 255．255．255．0；第二，由于现在ADSL MO- DEM成为了网关，所以，在配置客户机时，默认网关地址应填写ADSL MODEM的IP地址，而DNS服务器地址也是同样(图7)。

图7

    至此，我们已经成功地实现了通过 ADSL MODEM的路由功能进行Internet共享。现在客户机开机后就可以上网了，感觉和专线上网差不多，非常方便。


ADSL共享上网方式总结（图解）III

三、宽带路由器实现共享

    前面我们详细讲述了如何用路由式ADSL MODEM+集线器(或交换机)实现多机共享。大家也已经知道如果对于非路由式ADSL MODEM，可以采用代理服务器或网关方式来共享。但若没有路由ADSL MODEM，就非得采用代理服务器或网关模式呜?不!还有一种解决方案： 非路由ADSL MODEM+宽带路由器。

    宽带路由器也是一种共享上网设备，同路由式ADSL MODEM相似，它也具有“路由”的功能，可以取代代理服务器的位置而成为客户机的“网关”。客户机就通过这个“网关”来上网。而且，多数宽带路由器还自带有4口或者5口交换机，客户机只要把网线插在宽带路由器的交换机口中，再进行简单的配置就可以上网了。

    宽带路由器支持多种Internet接人方式的共享，例如 ADSL、FTTB+LAN(光纤到楼+局域网到户)、闭路线宽带(即 Cable MODEM)、普通56Kbps MODEM拨号上网等。不过，对子ADSL接入方式，它只支持以太式ADSl MODEM。

    下面，我们依旧以Windows 2000平台为基础，以ASUS(华硕)AAM6000EV非路由以太式ADSL MODEM和TP-Link(普瑞尔)TL-R400宽带路由器为例，来讲解宽带路由器共享ADSL的方法(其他品牌的宽带路由器在设置界面上会有所不同，但要设置的地方和具体设置内容几乎都是相同的)。

    首先，确保ADSL MODEM212作正常，即我们已经能够通过它上网。然后，我们切断计算机和ADSL MODEM的电源，把 TL-R400宽带路由器连接进来。

    TL-R400宽带路由器如图1所示

图1

    它是专门针对家庭用户和小型办公室而开发的共享上网设备。它集成了4口10／ 100Mbps交换机，用于连接需要上网的用户计算机。而背面板上的WAN口，则是用来连接ADSL MO- DEM等网络接人设备的。它的组网方式如图2所示。

图2

    1.宽带路由器的配置

    现在，我们要对TL-R400宽带路由器进行简单的配置，让它能够代替计算机进行自动拨号。

    同大多数以太式ADSL MODEM一样，TL-R400宽带路由器也具有一个IP地址，且采用Web页管理方式。我们可以在 IE浏览器地址栏中输入“http：／／xxx．xxx． XXX．XXX'’进入管理页面来对它进行设置。 TL-R400出厂时默认的IP地址是“192．168．123．254'’， 子网掩码为“255．255．255．0"。我们要注意，现在直接在计算机的IE浏览器地址栏中输入"http：／／ 192．168．123．254"是无法访问管理页面的，道理很简单：IP地址要处于同一个网段才可以进行访问。于是我们首先要修改计算机本地连接的IP地址。

    进入局域网中任意一台计算机系统“本地连接”的"TCP／IP属性”对话框。在该对话框中，将IP地址设置为"192．168．123． x”(x为1-253的自然数)，同时将网关设置为“192．168．123．254"。连续两次“确定”后，设置立即生效。现在，我们可以在IE地址栏中输入"http：／／192．168．123．254"进入 TL-R400的管理页面了。

    在出现的登录页面左侧登录框输入默认密码"admin”进入管理页面。在管理页面左侧的菜单中，选择"Primary Setup'’ (主要设置)项，出现如图3所示的对话框。

图3

    在该对话框中，显示有TL-R400的默认IP地址以及WAN(广域网)的类型，默认为“Dynamic IP Address”(动态IP地址)。点击“Change”(更改)按钮，进入图4所示对话框。

图4

    在该对话框中，我们须点选“PPP over Ethernet'’ 来将 WAN类型更 改 为‘‘PPPoE'’ (局域网上的点对点协议)，这是因为ADSL拨号采用的是该协议。点选后，点击"Save”按钮进入下一步的对话框。在这里，我们要填写ADSL的账号和密码(即ISP提供给你的ADSL用户名和密码)，以后，拨号的任务就交给TL-R400了。填写完毕后保存设置。不过且慢!!我们仔细思考网上数据传送到用户计算机的过程，是从 InternetADSL MODEM宽带路由器本机，而前面我们已经看到为了访问宽带路由器，我们必须将本地连接的IP地址段和宽带路由器的IP地址段统一起来才行，那么，进而联想到ADSL MODEM的默认私有IP地址是“192．168．1．1”(多数以太式 ADSL MODEM出厂默认IP地址都是“192．168．1．1”)， 子 网 掩 码 为“255．255．255．0'。很显然，和“192．168．254． x”不在一个网段上，也就是说，这时TL— R400是无法访问ADSL MODEM的，数据也无法传送。只有当ADSL MODEM、宽带路由器、本地连接三者的IP地址段一致的时候，才能实现互访和数据传输!所以，我们还要对 TL-R400的IP地址进行修改，我们建议将IP地址修改成与 ADSL MODEM同网段，例如本例的“192．168．1．2”，子网掩码“255．255．255．0'’ (图5)。

图5

    最后点击"Save”按钮保存设置，并点击"Reboot”按钮立即重新启动TL-R400宽带路由器使设置生效。

ADSL共享上网方式总结（图解）III

2.客户机的配置

    当TL-R400重启后，会弹出一个显示有“System is restarted Please reconnect manually”(系统已重启，请手动连接)字样的对话框让我们重新连接管理页面。这时你在IE地址栏中输入"http：／／192．168．1．2”也已无法访问该管理页面了，因为TL— R400的IP地址段已做了修改，和现有本地连接的IP地址又不在一个段上了，所以现在我们需要重新配置客户机。进入“本地连接”的“TCP／IP属性”对话框，在这里，将IP地址修改为"192．168．1． x”(x为3~254的自然数)(本例中为"192．168．1．3)，子网掩码依旧是"255．255．255．0"。由于TL-R400取代了以前的网关计算机，自身成为了一个“网关”，所以这里我们将“网关”设置为TL— R400的IP地址“192．168．1．2”。 由于采用的是“网关”式共享，那么客户机的DNS服务器也应该指向“网关”，即“192．168．1．2”(图6)

图6

    3.宽带路由器拨号连接Internet

    现在，ADSI MODEM、宽带路由器、本地连接的私有IP地址都处在同一个网段下，能够实现数据传送了。

    在IE地址栏中输入“http：／／192．168．1．2”并“回车”，然后输入管理密码进入TL-R400管理页面，点右下角的"Connect”按钮进行拨号连接。等待约5秒钟后，连接成功，同时TL-R400将显示获得的公有IP地址、ISP的DNS服务器地址等信息 (图7)。

图7

    现在客户机可以上网了。打开IE，输入网址—— GO！！

    以后要上网时，只要将 ADSL MO— DEM和TL— R400的电源打开，TL— R400就会自动拨号连接上 Internet。这时计算机登录后，就可以直接上网了，无须任何额外的操作。如果不想上网了，关闭TL-R400的电源即可。

    TL-R400支持4台计算机共享上网，如果多于 4台计算机，可以再加一个集线器(或交换机)，组网方式如图8。


分步讲解家庭组网常用的三种方式

近年来，计算机价格下降很快，硬件产品的更新更是一日千里，许多家庭都渐渐添置了两台，甚至两台以上的电脑。再加上网络的普及，组建家庭网络就逐渐提上了日程。

大家都知道，家庭组网是一项经济便利的选择，它不仅方便了数据的交换，而且可大幅度地降低后置PC的投资。文件共享使得你可以在一台机子上访问另外一台机子的文档；家庭成员对打网络游戏，其乐融融。

那么，或许有人要问，如何建立家庭网络呢？会不会很复杂呢？鉴此，我们结合图形给大家介绍一下家庭组网的三种基本方式，希望能给大家带来帮助。

一、简单的家庭网络

组网结构图

我们针对有线家庭网络的特点提出以下两种构建方式。

两台电脑：

如果一个家庭只有两台电脑，则通常采用电缆直连方法。电缆又分好几种,一种是双绞线电缆；另一种是并行电缆；还有就是串行电缆。

现在大多数都是使用双绞线,还需要以下几个设备:

·两块以太网卡，当然最好是现在主流的10／100Mbps快速以太网卡；

·一条经过跳（1－3，2－6跳线法）的五类以上双绞线，不过最长距离限为100米。连接宽带终端设备的网线购买设备时已有。

硬件设置：

使用"直接电缆连接"，两台机子的距离不能太远，一般以一个房间为限，因为电缆线的长度是有限的嘛，太长了不方便。接下来将串行/并行电缆的两端分别插入两台机子的串行/并行口中，这是很关键的一步，请参照下图所示操作：

串行/并行电缆对联表

软件设置：

第一步：选定一台作为主机，依次点击Windows中的"开始"→"程序"→"附件"→"通讯"→"直接电缆连接"，这时会弹出设置向导，选中主机选项按钮；

第二步：计算机将会自动检测可用的的并口和串口，选择所需要的端口，然后根据提示操作。

第三步：在客户机上重复操作上面步骤，注意在设置向导中请选客户机按钮。这样两台计算机的连接可以建立完成，当需要连接以便传输数据时，请按以下步骤操作：

    （1）：打开主机中的"开始"→"程序"→"附件"→"通讯"→"直接电缆连接"，点击"侦听"。

    （2）：打开客户机中"开始"→"程序"→"附件"→"通讯"→"直接电缆连接"，点击 "连接"。

这样，两台机子便可以访问共享出来的文件夹以及进行数据传输了。

如果需要改变主机与客机的关系，该怎么办呢？这时就需要重新进行设置。照例在主机或客户机上点击运行"开始"→"程序"→"附件"→"通讯"→"直接电缆连接"，单击"更改"按钮，即可弹出"直接电缆连接"向导，然后参照先前的设置过程重新定义主客机的关系就可以了。

注意事项：

事实上这并不是严格意义上的"网络"，但因为无须购买新的设备，做到了花最少的钱取得最大的效益，不失为双机互连的最经济、最方便的一种方法。但这种方法也不无缺点，具体表现在两机互访时需要频繁地重新设置主机客关系，另外，数据传输速率较慢，仅适合于双机交换数据或是简单的连机游戏。

最后把直接连接宽带设备的电脑作为网关（或代理）服务器，安装相应的网关（或代理）服务器软件，如Sygate、Wingate等软件，然后再进行相应的配置，即可实现网关型或代理服务器型宽带共享。

三台电脑:

以上是不采用网络连接设备的方法，要实现宽带接入共享，最好接上相应的宽带终端设备，如ADSL的ADSL Modem，CM的Cable Modem，目前主流的这两种Modem都是以太网接口的，所以也需要用网卡连接，这样就还需在其中一台电脑中安装多一块网卡。

在这种配置情况中，通常也可能有多种具体共享方案。在这里我们细分出来两种主要方案，一种是无需任何集线设备，即不用集线器和交换机，只需通过网卡实现三台电脑的互联。另一种方案我们将在后面提到。

前一方案所需设备如下：

·5块10／100Mbps以太网卡（其中一块用于宽带连接）。

·2条经过跳（1－3，2－6跳线法）的五类以上双绞线，不过最长距离限为100米。同样连接宽带终端设备的网线购买设备时已有。

采用双网卡网络连接的实现方法，实际上就是在其中一台电脑中安装双块网卡，作为“网络桥接器”（即“网桥”），这两块网卡都用于局域网连接，而不是用来连接其它电脑，宽带也通过一块以太网卡连接在另一台电脑中，实现共享。其硬件设置，软件设置同上。

总结该方式，我们可发现它具有两个非常明显的优点，一是连接简单；二是投资极少。当然，其缺点就是必须要有一台主机做服务器，其他机器要上网时，服务器必须开机。

二、利用路由器或交换机或集线器（选其一）

组网结构图

当共享电脑超过3台（一般是多家庭共享），我们建议大家采取如下方案：

1.路由器方案

这种方案是指仅通过宽带路由器来实现，因为现在的宽带路由器所提供的交换端口基本上都为4口，所以最多只能直接连接4台电脑，这样这种共享方案也就只适用于4台电脑的情况。

所需设备如下：

·4块10／100Mbps以太网卡（宽带设备直接连接在宽带路由器的WAN端口）；

·含4口以上的宽带路由器

·5条五类以上直通双绞线，每条长度限为100米（原购买宽带设备时提供的网线为交叉的，仅适用于与电脑直连，不能用于与交换机或路由器直连）。

在这种方案中，就无需单独一台电脑长期开启，当各用户需要上网时，只需打开路由器即可上网，非常方便。

网络连接好后，可以在浏览器中直接输入路由器的默认IP地址和用户帐号、密码（通常为192.168.1.1，用户帐号和密码通常都为“admin”，可查看相应路由器的使用手册得知，然后在Web界面中配置路由器各协议，添加用户（可采用路由器的DHCP服务自动分配IP地址）；如果是PPPOE虚拟拨号用户，则还可配置路由器的PPPOE协议，使它能自动或手动拨号，代替计算机用户直接拨号。各种用户访问权限的配置也可以在路由器中通过Web配置界面进行详细配置，由此实现“代理型”共享功能。

2.集线器＋路由器方案

如果用户数超过4个，主要是多家庭或者小型企业共享使用，因为宽带路由器只有4个交换式LAN端口，所以先要求对部分用户用集线器集中连接起来，然后再用直通双绞线与路由器LAN端口连接。所需设备如下：

·n块（相应用户数）10／100Mbps以太网卡；

·桌面型集线器；

·含4个交换端口的宽带路由器；

·n＋1条五类以上直通双绞线，其中一条用于宽带设备与路由器的连接。1条五类以上交叉双绞线，用于集线器的普通端与路由器的普通端口连接，如果是采用集线器的UPLink端口与路由器普通端口连接，则需要一条直通五类以上双绞线，而不用交叉线。

同样，在这种方案中，当各用户需要上网时，只需打开路由器，接上集线器，即可轻松上网，非常方便。

3.集线器+（路由器）+交换机方案

如果用户数目更多，如网吧或者中等企业等，这时就要采用交换机了。如果认为没必要采用路由共享方式，也就没必要购买宽带路由器，此时可以采用集线器或者交换机集中连接即可，用其中一台性能最好，连接方便的计算机担当网关服务器或者代理服务器，通过代理服务器软件为各用户配置具体的访问权限和互联网应用，网关型不可配置访问权限。这种方案所需设备如下：

·桌面型集线器或交换机；

·n块10／100Mbps以太网卡；

·n（用户数）＋1条五类以上直通双绞线，其中一条用于宽带设备与集线器或者交换机相连，因为购买宽带设备时所提供的网线仅适用于直接连接电脑用，不是交叉线，不能用于连接交换机或集线器的普通端口上。

当然宽带终端设备也可以通过在其中一台计算机上安装两块网卡，而直接连接在其中担当网关或者代理服务器的计算机上。

优点：各机可以单独上网，没有服务器的麻烦

缺点：需添置一定的硬件设备。稳定性受中间设备影响。

三、无线家庭组网

组网结构图

与有线网络相比较，无线网络更灵活、更方便、更安全、适应性更强、操作也更简单，让人能够真正体会到网络无处不在的奇妙感觉！

要能无线上网，首先必须要有AP。AP的全称叫做Access Point，也就是接入点，借助于AP，既可以实现无线与有线的连接，也可以实现无线网络的Internet共享。

目前，许多网络设备提供商都有自己的无线网络产品，知名的品牌如美国的CISCO和NETGEAR，台湾的D-Link和Accton，大陆的华为3COM和神州数码等等。大家可根据自己家庭网络环境及经济承受能力，挑选适合自己的无线网络产品。

由于无线网络无需使用集线设备，因此，仅仅在每台台式机或笔记本电脑插上无线网卡，即可实现计算机之间的连接，构建成最简单的无线网络。其中一台计算机可以兼作文件服务器、打印服务器和代理服务器，并通过Modem或ADSL接入Internet。这样，只需使用诸如Windows 9x/Me、Windows 2000/XP等操作系统，就可以在服务器的覆盖范围内，不用使用任何电缆，在计算机之间共享资源和Internet连接了。在该方案中，台式计算机和笔记本电脑均使用无线网卡。

无线网络的设置

第1步，在控制面板中打开“网络连接”窗口。

第2步，右键单击“无线网络连接”图标，在快捷菜单中单击“属性”，显示“无线网络连接属性”对话框。

第3步，选择“无线网络配置”选项卡，并选择“用Windows来配置我的无线网络配置”复选框，启用自动无线网络配置。

第4步，单击“高级”按钮，显示“高级”对话框。

第5步，选择“仅计算机到计算机（特定）”选项，实现计算机之间的连接。若既直接连接至计算机，又保留连接至接入点的功能，可选择“任何可用的网络（首选访问点）”选项。

需要注意的是，在首选访问点无线网络中，如果有可用网络，通常会首先尝试连接到访问点无线网络。如果访问点网络不可用，则尝试连接到计算机到计算机无线网络。例如，如果工作时在访问点无线网络中使用笔记本电脑，然后将笔记本电脑带回家使用计算机到计算机家庭网络，自动无线网络配置将会根据需要更改无线网络设置，这样无需用户作任何设置就可以直接连接到家庭网络。

第6步，依次单击“关闭”和“确定”按钮，建立计算机之间的无线连接，显示信息框，提示无线网络连接已经连接成功。

无线网卡无需设置IP地址，只需采用默认的自动获取IP地址，即可实现计算机之间的连接。若需借助于一台计算机作为代理服务器从而实现Internet连接，则只需在同时接入Internet（或者是ADSL或者是小区宽带）和无线网络的计算机中，打开网络连接窗口，然后，再该窗口左侧的“网络任务”栏中单击“设置家庭和小型办公网络”超级连接，运行“网络安全向导”，将该计算机配置为ICS主机。然后，再在其他计算机上也运行“网络安装向导”，并设置为客户端即可。

无线上网方式使用方便，某一台机器上网登录非常方便，但它也有一些缺点，如投资较大，同时无线受环境影响难免有断线机率。


ADSL共享上网方式大总结（图解）

ADSL共享上网方式大总结（图解）I

ADSL共享上网方式大总结（图解）Ⅱ

ADSL共享上网方式大总结（图解）III

分步讲解家庭组网常用的三种方式

PPPOE拨号,双网卡共享上网(含双机互连)


PPPOE拨号,双网卡共享上网(含双机互连)

注意:
LAN和PPPOE方式类似, 如果是双机互连,2台电脑间需要用13,26对调的交叉线,请仔细阅读后面的问题集锦。

先看一下网线布局:

主机设置第一步:如下图,网络邻居-查看网络连接,我这里"ADSL"是电信的PPPOE拨号,网通也有类似的拨号上网方式。
这里有2个网卡,Local Area Connection（本地链接）这个是布线图中的网卡A，也就是跟外网连的网卡。
Local Area Connection 2（本地链接 2）就是布线图中的网卡B,连交换机或者HUB的UPLINK的网卡。

第二步,如下图,我们右键点击图中的ADSL－属性－高级－选中图中的2个选项。
第一个是设置该网络链接共享给其他网络的,这里我们选中Local Area Connection2,把网络共享给网卡B,这样内网的客户端电脑也可以通过网卡B来上网了。
第二个可选可不选,作用是如果内网有电脑要上网,他会自动拨号。
这里还有一个Windows自带的防火墙,如果共享有问题,可以手工设置防火墙或者干脆关闭。不过,主机必要的安全措施还是要的,建议使用一套网络防火墙+企业级杀毒软件。

点击确定以后,弹出提示对话框,点击确定即可。XP/2K会自动设置网卡B的IP和掩码，如果没有自动设置，请手工指定一下IP。如下图

把网卡B和交换机或者HUB的UPLINK相连。网内客户端电脑IP如果无法自动获取，就手工指定IP地址：192.168.0.2-255，掩码：255.255.255.0，网关：192.168.0.1，只要IP地址位数不一样就行，如果客户端电脑打开网页出现DNS解析错误，请手工设置ISP提供的DNS地址。方法：开始－运行－cmd－ ipconfig/all 可以查询到DNS地址。 （如下图,DNS Servers ...右边显示的就是ISP提供的DNS服务器）

问题集锦：

1.我的网络接入是LAN,而不是PPPOE拨号
解决：方法类似,第一步设置共享是在本地连接中指定共享。（总的思路是这样：外网－网卡A－网卡A共享给网卡B－网卡B是网关－网内客户端通过网卡B上网）

2.网线制作不当导致网络连接失败或者丢包。
解决：请参考 《丢包不一定是网卡的问题－网线你做对了吗》 一文（转自isso论坛）。双机互连2台电脑间需要用13,26对调的交叉线。

3.主机上网正常,但是客户端打开网页速度很慢,有些网页能打开有些不能,能打开首页但是不能打开里面的链接。
解决：排除网线制作问题。在客户端电脑上,开始－运行－cmd,在命令提示窗口中:
c:\>ping 192.168.0.1 -f -l 1500 如果返回来的信息是
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.
Packet needs to be fragmented but DF set.

    就说明该大小的（1500字节）数据包超过了ISP的MaxMTU，产生了数据冲突碎片，那么我们就降低Ping命令中的数据包大小，比如1470，一直到返回信息是 ：
Reply from 192.168.0.1: bytes=32 time=20ms TTL=244
Reply from 192.168.0.1: bytes=32 time=10ms TTL=244
Reply from 192.168.0.1: bytes=32 time=11ms TTL=244
Reply from 192.168.0.1: bytes=32 time=10ms TTL=244
那么这个数据包大小的值就是ISP的PPPoE协议的MaxMTU值。

找到这个数值以后，我们需要逐个修改各个客户端的注册表TCP/IP参数。

    对于客户端是Windows 95/98/ME 操作系统，我们需要找到该项目： HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet \Services\Class\NetTrans\000x\MaxMTU (STRING Value)

    此处的000x所指的是客户端电脑连接Winroute服务器的那块局域网网卡，首先增加MaxMTU键，类型为字串，然后设定值为ISP的PPPoE的MaxMTU值。

    客户端是Windows 2000/xp 操作系统，修改注册表项目HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl Set\Services\Tcpip\Parameters\Interfaces\"网卡"\MTU (DWORD Value)

    "网卡"指客户端电脑连接Winroute服务器的那块局域网网卡。增加MTU键值，类型为二进制字串，值为ISP的PPPoE协议的MaxMTU值。